1- Interface, LLDP, MPLS &and LDP
2- RID, AS#, BGP
3- L3VPN: VRF, RD, RT
4- virtual CE: VR
#1- Interface, LLDP, MPLS & LDP ( on theSRX340 MX480 )
#---------------------------
set interfaces ge-10/30/45 unit 0 family inet address 10.17.0.21/24
set protocols lldp interface allinterfaces ge-0/0/5 unit 0 family mpls
set protocols mpls interface ge-10/30/45.0
set protocols ldp interface ge-10/30/45.0
set protocols ldplldp interface fxp0.0 disable
set interfaces lo0.210 family inet address 10.210.2.2/32
set routing-instances vrf_1 interface lo0.210
ge-0/0/5
set protocols lldp interface all
#2- RID, AS#, BGP ( on the MX480SRX340 )
#-------------------------------
set routing-options router-id 10.30.9295.193210
set routing-options autonomous-system 1.65535
set protocols bgp group iBGP type internal
set protocols bgp group iBGP local-address 10.17.0.21
set protocols bgp group iBGP family inet-vpn unicastneighbor 10.17.0.2
set protocols bgp group iBGP neighbor 10.17.0.1family inet-vpn unicast
#3- L3PVN:L3VPN VRF, RD, RT ( on the MX480SRX340 )
#---------------------------------------
set interfaces lo0.210 family inet address 10.210.1.1/32
set routing-instances vrf_1 interface lt-10/0/100.31
set routing-instances vrf_1 interface lo0.210
set routing-instances vrf_1 instance-type vrf
set routing-instances vrf_1 route-distinguisher 65535:1717
set routing-instances vrf_1 vrf-target import target:65536L:1717
set routing-instances vrf_1 vrf-target export target:65536L:1717
set routing-instances vrf_1 routing-options router-id 10.210.21.21
set routing-instances vrf_1 routing-options autonomous-system 1101
set routing-instances vrf_1 protocols bgp group eBGP type external
set routing-instances vrf_1 protocols bgp group eBGP local-address 10.217.21.2
set routing-instances vrf_1 protocols bgp group eBGP neighbor 10.217.21.1 peer-as 102
#set routing-instances vrf_1 protocols bgp group eBGP 101
#CE configuration:
#-----------------
set interfaces lt-0/0/0 unit 30 encapsulation ethernet
set interfaces lt-0/0/0 unit 30 peer-unit 31
set interfaces lt-0/0/0 unit 30 family inet address 10.217.1.1/30
set interfaces lt-0/0/0 unit 31 encapsulation ethernet
set #CE config on MX480
#-------------------
# check the lt and apply the BW
show chassis hardware
set chassis fpc 0 pic 0 tunnel-services bandwidth 1g
>>>>> check the lt interface created could be lt-0/0/10??
## check the lt and apply the BW
show chassis hardware
set chassis fpc 0 pic 0 tunnel-services bandwidth 1g
>>>>> check the lt interface created could be lt-0/0/10??
## check the lt and apply the BW
show chassis hardware
set chassis fpc 0 pic 0 tunnel-services bandwidth 1g
>>>>> check the lt interface created could be lt-0/0/10??
## check the lt and apply the BW
show chassis hardware
set chassis fpc 0 pic 0 tunnel-services bandwidth 1g
>>>>> check the lt interface created could be lt-0/0/10??
#interfaces lt-0/0/0 unit 31 peer-unit 30
set interfaces lt-0/0/0 unit 31 family inet address 10.217.1.2/30
set interfaces lo0 unit 217 family inet address 10.217.0.1/32
set routing-instances ce_vr instance-type virtual-router
set routing-instances ce_vr interface lt-0/0/0.30
set routing-instances ce_vr interface lo0.217
set routing-instances ce_vr routing-options router-id 10.217.0.1
set routing-instances ce_vr routing-options autonomous-system 101
set routing-instances ce_vr protocols bgp group eBGP type external
set routing-instances ce_vr protocols bgp group eBGP local-address 10.217.1.1
set routing-instances ce_vr protocols bgp group eBGP neighbor 10.217.1.2 peer-as 1101
# export protocol direct into BGP
set policy-options policy-statement exp_protocol_direct from protocol direct
set policy-options policy-statement exp_protocol_direct then accept
set routing-instances ce_vr protocols bgp group eBGP export exp_protocol_direct
|