Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

...

PE configR1#show running-config ! ! Software version: DEMO_VM-OcNOS-SP-MPLS-x86-6.4.1.32-GA 11/04/2023 18:55:29 ! !Last configuration change at 18:56:29 UTC Sat Dec 23 2023 by ocnos ! ! feature netconf-ssh feature netconf-tls ! no service password-encryption ! snmp-server enable traps link linkDown snmp-server enable traps link linkUp ! ip vrf management ! qos enable ! ! hostname R1 ip domain-lookup errdisable cause stp-bpdu-guard no feature telnet feature ssh feature ntp ntp enablefeature rsyslog ! interface lo ip address 127.0.0.1/8 ip address 10.10.100.1/32 secondary ipv6 address ::1/128 ! interface eth0 ip address 192.168.0.201/24 ! interface eth1 ip address 192.168.12.1/30 mtu 9216 label-switching mpls ldp-igp sync ospf ip ospf network point-to-point enable-ldp ipv4 ! interface eth2 ip address 192.168.13.1/30 mtu 9216 label-switching mpls ldp-igp sync ospf ip ospf network point-to-point enable-ldp ipv4 ! interface eth3 ! interface eth4 ! interface eth5 ! interface eth5.1 switchport ! exit ! end
Interfaces


Code Block
titleinterfaces
interface lo
 ip address 127.0.0.1/8
 ip address 10.10.100.1/32 secondary
 ipv6 address ::1/128
!
interface eth0
 ip address 192.168.0.201/24
!
interface eth1
 ip address 192.168.12.1/30
 mtu 9216
 label-switching
 mpls ldp-igp sync ospf
 ip ospf network point-to-point
 enable-ldp ipv4
!
interface eth2
 ip address 192.168.13.1/30
 mtu 9216
 label-switching
 mpls ldp-igp sync ospf
 ip ospf network point-to-point
 enable-ldp ipv4
!
interface eth5
!
interface eth5.1 switchport
!

#

OSPF config


Code Block
titleOSPF
router ospf 1
 ospf router-id 10.10.100.1
 passive-interface lo enable
 network 10.10.100.8/32 area 0.0.0.0
 network 192.168.12.0/30 area 0.0.0.0
 network 192.168.13.0/30 area 0.0.0.0



interface lo
 ip address 10.10.100.20/32 secondary
!
interface eth1
 ip ospf network point-to-point
!
interface eth2
 ip ospf network point-to-point
!


VPLS configMPLS & LDP Config


Code Block
title
vpls
LDP
mpls vpls DEMO-VPLS 10
 signaling ldp
  vpls-peer 10.10.100.3
  vpls-peer 10.10.100.4
  exit-signaling
 exit-vpls

!
router ldp
 router-id 10.10.100.1
 inter-area-lsp eth1
 session-protection
 targeted-peer ipv4 10.10.100.3
  exit-targeted-peer-mode
 targeted-peer ipv4 10.10.100.4
  exit-targeted-peer-mode
 transport-address ipv4 10.10.100.1



Other config
PE config


Code Block
titlevpls
R1#show running-config
!
! Software version: DEMO_VM-OcNOS-SP-MPLS-x86-6.4.1.32-GA 11/04/2023 18:55:29
!
!Last configuration change at 18:56:29 UTC Sat Dec 23 2023 by ocnos
!
!
feature netconf-ssh
feature netconf-tls
!
no service password-encryption
!
snmp-server enable traps link linkDown
snmp-server enable traps link linkUp
!
ip vrf management
!
qos enable
!


end


VPLS Config


Code Block
titleVPLS
Here