...
Code Block | ||||
---|---|---|---|---|
| ||||
# Mesh Topology # +---------+ +---------+ # | spine01 | | spine02 | # +---------+ +---------+ # |em4 \ em5 em5 / em4| # | \ / | # | \ / | # | \ / | # | \/ | # | / \ | # | / \ | # | / \ | # |em4 / em5 em5 \ em4| # +---------+ +---------+ # | leaf03 | | leaf04 | # +---------+ +---------+ | ||||
Code Block | ||||
|
set interfaces lo0 unit 0 family inet address 10.0.0.1/32
set interfaces em3 unit 0 family inet address 192.168.0.0/31
set interfaces em5 unit 0 family inet address 192.168.0.2/31
set protocols ospf area 0.0.0.0 interface em3.0
set protocols ospf area 0.0.0.0 interface em5.0
set protocols ospf area 0.0.0.0 interface lo0.0 passive
set routing-options router-id 10.0.0.1
...
set
...
routing-options
...
autonomous-system
...
65100
set protocols bgp log-updown
set protocols bgp import bgp-ipclos-in
set protocols bgp export bgp-ipclos-out
set protocols bgp graceful-restart
set protocols bgp group IPCLOS type external
set protocols bgp group IPCLOS mtu-discovery
set protocols bgp group IPCLOS bfd-liveness-detection minimum-interval 350
set protocols bgp group IPCLOS bfd-liveness-detection multiplier 3
set protocols bgp group IPCLOS bfd-liveness-detection session-mode single-hop
set protocols bgp group IPCLOS multipath multiple-as
set protocols bgp group IPCLOS neighbor 192.168.0.1 peer-as 65200
set protocols bgp group IPCLOS neighbor 192.168.0.3 peer-as 65201
set protocols bgp group IPCLOS neighbor 192.168.0.5 peer-as 65202
set policy-options policy-statement bgp-ipclos-out term loopback from protocol direct
set policy-options policy-statement bgp-ipclos-out term loopback from route-filter 10.0.0.0/24 orlonger
set policy-options policy-statement bgp-ipclos-out term loopback then next-hop self
set policy-options policy-statement bgp-ipclos-out term loopback then accept
#set policy-options policy-statement bgp-ipclos-out term server-L3-gw from protocol direct
#set policy-options policy-statement bgp-ipclos-out term server-L3-gw from route-filter 172.16.0.0/12 orlonger
#set policy-options policy-statement bgp-ipclos-out term server-L3-gw then next-hop self
#set policy-options policy-statement bgp-ipclos-out term server-L3-gw then accept
set policy-options policy-statement bgp-ipclos-in term loopbacks from route-filter 10.0.0.0/24 orlonger
set policy-options policy-statement bgp-ipclos-in term loopbacks then accept
#set policy-options policy-statement bgp-ipclos-in term server-L3-gw from route-filter 172.16.0.0/12 orlonger
#set policy-options policy-statement bgp-ipclos-in term server-L3-gw then accept
set policy-options policy-statement bgp-ipclos-in term reject then reject
Code Block | ||||
---|---|---|---|---|
| ||||