1- L3 interface
2- BGP
Code Block | ||||
---|---|---|---|---|
| ||||
localhost#show interfaces status
Port Name Status Vlan Duplex Speed Type Flags
Et1 connected 1 full unconf EbraTestPhyPort
Et2 connected 1 full unconf EbraTestPhyPort
Ma1 connected routed a-full a-1G 10/100/1000
localhost#show ip interface brief
Interface IP Address Status Protocol MTU
Loopback0 10.0.0.1/32 up up 65535
Management1 10.0.2.15/24 up up 1500
| ||||
On spine01 and spine02
Code Block | ||||
---|---|---|---|---|
| Spine1:
-------
interface Ethernet1
no switchport
ip address 10.1.2.1/30
!
interface Loopback0
ip address 10.0.0.1/32
!
ip routing
!
router bgp 65000
router-id 10.0.0.1
neighbor 10.1.2.2 remote-as 65000
neighbor 10.1.2.2 maximum-routes 12000
network 10.0.0.1/32
!
Spine2:
-------
interface Loopback0
ip address 10.0.0.2/32
interface Ethernet1
no switchport
ip address 10.1.2.2/30
ip routing
router bgp 65000
router-id 10.0.0.2
neighbor 10.1.2.1 remote-as 65000
neighbor 10.1.2||||
.
...
.
show ip bgp summary
show ip bgp neighbors
...
Code Block | ||||||
---|---|---|---|---|---|---|
| spine01#show ip bgp summary
BGP summary information for VRF default
Router identifier 10.0.0.1, local AS number 65000
Neighbor Status Codes: m - Under maintenance
Neighbor V AS MsgRcvd MsgSent InQ OutQ Up/Down State PfxRcd PfxAcc
10.1.2.2 4 65000 39 44 0 0 00:34:00 Estab 1 1
spine01#show ip bgp neighbors
BGP neighbor is 10.1.2.2, remote AS 65000, internal link
BGP version 4, remote router ID 10.0.0.2, VRF default
Negotiated BGP version 4
Last read 00:00:10, last write 00:00:10
Hold time is 180, keepalive interval is 60 seconds
Configured hold time is 180, keepalive interval is 60 seconds
Connect timer is inactive
Idle-restart timer is inactive
BGP state is Established, up for 00:35:10
. . . .
spine01#show ip bgp neighbors 10.1.2.2 routes
BGP routing table information for VRF default
Router identifier 10.0.0.1, local AS number 65000
Route status codes: s - suppressed, * - valid, > - active, # - not installed, E - ECMP head, e - ECMP
S - Stale, c - Contributing to ECMP, b - backup, L - labeled-unicast
Origin codes: i - IGP, e - EGP, ? - incomplete
AS Path Attributes: Or-ID - Originator ID, C-LST - Cluster List, LL Nexthop - Link Local Nexthop
Network Next Hop Metric LocPref Weight Path
* > 10.0.0.2/32 10.1.2.2 0 100 0 i
spine01#show ip bgp neighbors 10.1.2.2 advertised-routes
BGP routing table information for VRF default
Router identifier 10.0.0.1, local AS number 65000
Route status codes: s - suppressed, * - valid, > - active, # - not installed, E - ECMP head, e - ECMP
S - Stale, c - Contributing to ECMP, b - backup, L - labeled-unicast, q - Queued for advertisement
Origin codes: i - IGP, e - EGP, ? - incomplete
AS Path Attributes: Or-ID - Originator ID, C-LST - Cluster List, LL Nexthop - Link Local Nexthop
Network Next Hop Metric LocPref Weight Path
* > 10.0.0.1/32 10.1.2.1 - 100 - i
spine01#show ip bgp neighbors 10.1.2.2 received-routes
BGP routing table information for VRF default
Router identifier 10.0.0.1, local AS number 65000
Route status codes: s - suppressed, * - valid, > - active, # - not installed, E - ECMP head, e - ECMP
S - Stale, c - Contributing to ECMP, b - backup, L - labeled-unicast
Origin codes: i - IGP, e - EGP, ? - incomplete
AS Path Attributes: Or-ID - Originator ID, C-LST - Cluster List, LL Nexthop - Link Local Nexthop
Network Next Hop Metric LocPref Weight Path
* > 10.0.0.2/32 10.1.2.2 - 100 - i
||||||
show ip route
Code Block | ||||||
---|---|---|---|---|---|---|
| localhost#show ip route
VRF: default
Codes: C - connected, S - static, K - kernel,
O - OSPF, IA - OSPF inter area, E1 - OSPF external type 1,
E2 - OSPF external type 2, N1 - OSPF NSSA external type 1,
N2 - OSPF NSSA external type2, B I - iBGP, B E - eBGP,
R - RIP, I L1 - IS-IS level 1, I L2 - IS-IS level 2,
O3 - OSPFv3, A B - BGP Aggregate, A O - OSPF Summary,
NG - Nexthop Group Static Route, V - VXLAN Control Service,
DH - Dhcp client installed default route
Gateway of last resort:
K 0.0.0.0/0 [40/0] via 10.0.2.2, Management1
B I 10.0.0.1/32 [200/0] via 10.1.2.1, Ethernet1
C 10.0.0.2/32 is directly connected, Loopback0
C 10.0.2.0/24 is directly connected, Management1
C 10.1.2.0/30 is directly connected, Ethernet1
localhost#show ip route bgp
VRF: default
Codes: C - connected, S - static, K - kernel,
O - OSPF, IA - OSPF inter area, E1 - OSPF external type 1,
E2 - OSPF external type 2, N1 - OSPF NSSA external type 1,
N2 - OSPF NSSA external type2, B I - iBGP, B E - eBGP,
R - RIP, I L1 - IS-IS level 1, I L2 - IS-IS level 2,
O3 - OSPFv3, A B - BGP Aggregate, A O - OSPF Summary,
NG - Nexthop Group Static Route, V - VXLAN Control Service,
DH - Dhcp client installed default route
B I 10.0.0.1/32 [200/0] via 10.1.2.1, Ethernet1
||||||