Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.


VRF and Interface


Code Block
titleVRF
ip vrf l3vpn
 rd 10.10.100.1:2020
 route-target both 65002:2020
!
interface xe0.2020
 encapsulation dot1q 20
 ip vrf forwarding l3vpn
 ip address 192.168.201.1/24


LDP


MP-BGP vpnv4 and ipv4 vrf Link


Code Block
titleBGP vpnv4 and ipv4 vrf
collapsetrue
R2#show running-config router bgp
!
router bgp 65000
 bgp router-id 10.1.1.1
 neighbor 10.1.1.2 remote-as 65000
 neighbor 10.1.1.2 update-source 10.1.1.1
 !
 address-family vpnv4 unicast
 neighbor 10.1.1.2 activate
 exit-address-family
 !
 address-family ipv4 vrf l3vpn
 redistribute connected
 exit-address-family
 !
 exit
!

Show commands


bgp

show

ip vrf

bgp neighbors

Code Block
title
vrf
aggr1#show ip vrf l3vpn
VRF l3vpn, VRF ID: 3, FIB ID 2
 Router ID: 192.202.100.1 (automatic)
Interfaces:
  lo.l3vpn
  xe0.2020
VRF l3vpn; default RD 10.10.100.1:2020
 RT:65002:2020
Import VPN route-target communities
 RT:65002:2020
No import route-map
No export route-map
VPNv4 label allocation mode: per-vrf
VPNv6 label allocation mode: per-vrf

show ip route vrf all database

Code Block
titleip route
#show ip route vrf l3vpn
Codes: K - kernel, C - connected, S - static, R - RIP, B - BGP
       O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2,
       ia - IS-IS inter area, E - EVPN,
       v - vrf leaked
       * - candidate default

IP Route Table for VRF "l3vpn"
C            127.0.0.0/8 is directly connected, lo.l3vpn, 03:01:41
C            192.168.201.0/24 is directly connected, xe0.2020, 02:52:46

Gateway of last resort is not set

show bgp vrf

Code Block
titlebgp vrf
#show bgp vrf l3vpn
show bgp neig
collapsetrue
Router1#show bgp neighbors
BGP neighbor is 10.10.11.2, remote AS 65000, local AS 65000, internal link, peer
 index: 2
  BGP version 4, local router ID 1.1.1.1, remote router ID 1.1.1.2
  BGP state = Established, up for 00:29:55
  Last read 00:00:08, hold time is 90, keepalive interval is 30 seconds
  Neighbor capabilities:
    Route refresh: advertised and received (old and new)
    Address family VPNv4 Unicast: advertised and received
  Received 74 messages, 0 notifications, 0 in queue
  Sent 74 messages, 0 notifications, 0 in queue
  Route refresh request: received 1, sent 1
  Minimum time between advertisement runs is 5 seconds
  Update source is 10.10.11.1

For address family: VPNv4 Unicast  BGP table version 2, neighbor version 2
  Index 1, Offset 0, Mask 0x2
  AIGP is enabled
  Community attribute sent to this neighbor (both)
  Large Community attribute sent to this neighbor
  1 accepted prefixes
  1 announced prefixes

 Connections established 1; dropped 0
Local host: 10.10.11.1, Local port: 179
Foreign host: 10.10.11.2, Foreign port: 40015
TCP MSS: (0), Advertise TCP MSS: (1448), Send TCP MSS: (1448),  Receive TCP MSS:
 (536)
Sock FD : (24)
Nexthop: 10.10.11.1
Nexthop global: ::
Nexthop local: ::
BGP connection: non shared network




show bgp vrf all

Code Block
titleshow bgp vrf
collapsetrue
Router1#show bgp vrf all
BGP table version is 1, local router ID is 192.
202
168.
100
11.1
Status codes: s suppressed, d damped, h history, a add-path, b back-up, * valid,
 > best, i - 
intern al
internal,
              l - labeled, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

    Network          Next Hop            Metric    LocPrf   Weight Path

BGP Route Table for VRF l3vpn
*> l 192.168.
201
11.0     0.0.0.0              0        100       32768  ?
*>i  192.168.
203
12.0     10.10.
100
11.
3
2           0        100       0    ?
*>i

192.168.204.0 10.10.100.4 0 100 0 ? Total number of prefixes 3

show bgp neighbors 10.1.1.2 received-routes 

Code Block
titlereceived-routes
#show bgp neighbors 10.10.100.3 received-routes % Inbound soft reconfiguration is not supported, displaying the received routes from acc essing BGP local RIB For address family: VPNv4 Unicast Status codes: s suppressed, d damped, h history, a add-path, * valid, > best, i - intern al, l - labeled
Total number of prefixes 2




Show VRF commands

show ip vrf

Code Block
titlevrf
aggr1#show ip vrf l3vpn
VRF l3vpn, VRF ID: 3, FIB ID 2
 Router ID: 192.202.100.1 (automatic)
Interfaces:
  lo.l3vpn
  xe0.2020
VRF l3vpn; default RD 10.10.100.1:2020
 RT:65002:2020
Import VPN route-target communities
 RT:65002:2020
No import route-map
No export route-map
VPNv4 label allocation mode: per-vrf
VPNv6 label allocation mode: per-vrf




show ip route vrf all database

Code Block
titleip route
#show ip route vrf l3vpn
Codes: K - kernel, C - connected, S - static, R - RIP, B - BGP
       O - OSPF, IA - OSPF inter area
       N1 - 
S
OSPF 
Stale
NSSA 
Origin
external 
codes: i - IGP
type 1, 
e
N2 - 
EGP,
OSPF 
?
NSSA 
-
external 
incomplete
type 2
      
Network
 E1 - OSPF external type 1, E2 - OSPF 
Next
external 
Hop
type 2
       i - 
Metric
IS-IS, L1 - 
LocPrf Weight Path Route Distinguisher: 10.10.100.3:2020 *>i 192.168.203.0 10.10.100.3
IS-IS level-1, L2 - IS-IS level-2,
       ia - IS-IS inter area, E - EVPN,
       v - 
0
vrf leaked
      
100
 * - candidate default

IP 
0
Route Table for VRF "l3vpn"
C 
?
  
Accepted
 
routes
 
count
 
=
 
1
  

show bgp neighbors 10.1.1.2 advertised-routes 

Code Block
titleadvertised
#show
 
bgp
 
neighbors
 
10
127.
10
0.
100
0.
3 advertised-routes For address family: VPNv4 Unicast BGP table version is 8, local router ID is 10.10.100.1 Status codes: s suppressed, d damped, a add-path, h history, * valid, > best, i - intern al Origin codes: i - IGP, e - EGP, ? - incomplete Network Next Hop
0/8 is directly connected, lo.l3vpn, 03:01:41
C            192.168.201.0/24 is directly connected, xe0.2020, 02:52:46

Gateway of last resort is not set


show BGP commands

show bgp vrf


Code Block
titlebgp vrf
#show bgp vrf l3vpn
BGP table version is 1, local router ID is 192.202.100.1
Status codes: s suppressed, d damped, h history, a add-path, * valid, > best, i - intern
al,
        
Metric
    
LocPrf
  l 
Weight
- 
Path
labeled, 
*>i
S 
192.168.201.0 10.10.100.1
Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

  
0
  Network      
100
    Next Hop  
32768
       
?
  
Total
 
number
Metric 
of
 
prefixes
 
1
 

show BGP summary

Code Block
titlesummary
#show bgp summary BGP router identifier 10.10.100.1, local AS number 65002 BGP table version is 8 1 BGP AS-PATH entries 0 BGP community entries Neighbor
LocPrf   Weight Path
*> l 192.168.201.0    0.0.0.0              0        100       32768  ?
V
*>i  192.168.203.0 
AS
   
MsgRcv
10.10.100.3    
MsgSen
 
TblVer
   
InQ
  0 
OutQ
    
Up/Down
   
Stat e/PfxRcd 10.1.1.240
100       0    ?
*>i  192.168.204.0  
4
 
65535 25493
 10.10.100.4          0        100       0    ?

Total number of prefixes 3



show bgp neighbors 10.1.1.2 received-routes 

Code Block
titlereceived-routes
#show bgp neighbors 10.10.100.3 received-routes
% Inbound soft reconfiguration is not supported, displaying 
29835
the received routes from acc
essing BGP 
8
local RIB

For address family: 
0
VPNv4 Unicast
Status codes: s 
0 01w1d20h 0 10.10.100.2
suppressed, d damped, h history, a add-path, * valid, > best, i - intern
al, l - labeled
              S 
4
Stale
65002
Origin 
67776
codes: i - IGP, e - EGP, ? - incomplete

     Network          Next Hop           Metric    LocPrf     Weight Path
Route 
67768
Distinguisher: 10.10.100.3:2020
*>i  192.168.203.0   
8
 10.10.100.3    
0
      0
 
22:50:35
       100       0 
10.10.100.3
   ?
 Accepted routes count = 1



show bgp neighbors 10.1.1.2 advertised-routes 

Code Block
titleadvertised
#show bgp 
4 65002 74025
neighbors 10.10.100.3 advertised-routes

For address family: VPNv4 Unicast
BGP table version is 8, local router ID is 10.10.100.1
Status codes: s suppressed, d damped, a add-path, h history, * valid, > best, i - intern
al
Origin codes: i - IGP, e - EGP, ? - incomplete

    
74045
Network       
8
   Next Hop  
0
      
0
  
02w3d23h
  Metric    LocPrf   Weight Path
*>i  
0
192.168.201.0    10.10.100.
4
1          0    
4
 
65002
 
67362
  100       32768  ?

Total number of prefixes 1



show BGP summary

Code Block
titlesummary
#show bgp summary
BGP router identifier 10.10.100.1, local AS number 65002
BGP table version is 8
1 BGP AS-PATH entries
0 BGP community entries

Neighbor      
67454
       
8
    V  
0
 AS   MsgRcv  
0
  
00:26:10
MsgSen TblVer   InQ   OutQ    Up/Down   
0
Stat
Total number of neighbors 4 Total number of Established sessions 4

show bgp neighbors 10.10.100.3

Code Block
titleshow
#show bgp neighbors 10.10.100.3
BGP neighbor is 10.10.100.3, remote AS 65002, local AS 65002, internal link, peer index:
 5
  BGP version 4, local router ID 10.10.100.1, remote router ID 10.10.100.3
  BGP state = Established, up for 02w4d00h
  Last read 00:00:14, hold time is 90, keepalive interval is 30 seconds
  Neighbor capabilities:
    Route refresh: advertised and received (old and new)
    Address family IPv4 Unicast: advertised and received
    Address family VPNv4 Unicast: advertised and received
    Address family L2VPN EVPN: advertised and received
  Received 74026 messages, 2 notifications, 0 in queue
  Sent 74045 messages, 3 notifications, 0 in queue
  Route refresh request: received 6, sent 6
  Minimum time between advertisement runs is 5 seconds
  Update source is lo

For address family: IPv4 Unicast  BGP table version 8, neighbor version 8
  Index 2, Offset 0, Mask 0x4
  AIGP is enabled
  Community attribute sent to this neighbor (both)
  Large Community attribute sent to this neighbor
  0 accepted prefixes
  0 announced prefixes


For address family: VPNv4 Unicast  BGP table version 3, neighbor version 3
  Index 2, Offset 0, Mask 0x4
  AIGP is enabled
  Community attribute sent to this neighbor (both)
  Large Community attribute sent to this neighbor
  1 accepted prefixes
  1 announced prefixes


For address family: L2VPN EVPN  BGP table version 26, neighbor version 26
  Index 2, Offset 0, Mask 0x4
  Community attribute sent to this neighbor (both)
  Large Community attribute sent to this neighbor
  2 accepted prefixes
  Accepted AD:0 MACIP:1 MCAST:1 ESI:0 PREFIX:0
  2 announced prefixes

 Connections established 5; dropped 4
Local host: 10.10.100.1, Local port: 179
Foreign host: 10.10.100.3, Foreign port: 33649
TCP MSS: (0), Advertise TCP MSS: (1460), Send TCP MSS: (1460),  Receive TCP MSS: (536)
Sock FD : (24)
Nexthop: 10.10.100.1
Nexthop global: ::
Nexthop local: ::
BGP connection: non shared network
Last Reset: 02w4d00h, due to BGP Notification received
Notification Error Message: (Cease/Other Configuration Change.)

uk-wnlb-lg-pol-cin-01#




L3 VPN
e/PfxRcd
10.1.1.240               4 65535 25493
                                                 29835       8      0      0  01w1d20h
             0
10.10.100.2              4 65002 67776
                                                 67768       8      0      0  22:50:35
             0
10.10.100.3              4 65002 74025
                                                 74045       8      0      0  02w3d23h
             0
10.10.100.4              4 65002 67362
                                                 67454       8      0      0  00:26:10
             0

Total number of neighbors 4

Total number of Established sessions 4



show bgp neighbors 10.10.100.3


Code Block
titleshow
#show bgp neighbors 10.10.100.3
BGP neighbor is 10.10.100.3, remote AS 65002, local AS 65002, internal link, peer index:
 5
  BGP version 4, local router ID 10.10.100.1, remote router ID 10.10.100.3
  BGP state = Established, up for 02w4d00h
  Last read 00:00:14, hold time is 90, keepalive interval is 30 seconds
  Neighbor capabilities:
    Route refresh: advertised and received (old and new)
    Address family IPv4 Unicast: advertised and received
    Address family VPNv4 Unicast: advertised and received
    Address family L2VPN EVPN: advertised and received
  Received 74026 messages, 2 notifications, 0 in queue
  Sent 74045 messages, 3 notifications, 0 in queue
  Route refresh request: received 6, sent 6
  Minimum time between advertisement runs is 5 seconds
  Update source is lo

For address family: IPv4 Unicast  BGP table version 8, neighbor version 8
  Index 2, Offset 0, Mask 0x4
  AIGP is enabled
  Community attribute sent to this neighbor (both)
  Large Community attribute sent to this neighbor
  0 accepted prefixes
  0 announced prefixes


For address family: VPNv4 Unicast  BGP table version 3, neighbor version 3
  Index 2, Offset 0, Mask 0x4
  AIGP is enabled
  Community attribute sent to this neighbor (both)
  Large Community attribute sent to this neighbor
  1 accepted prefixes
  1 announced prefixes


For address family: L2VPN EVPN  BGP table version 26, neighbor version 26
  Index 2, Offset 0, Mask 0x4
  Community attribute sent to this neighbor (both)
  Large Community attribute sent to this neighbor
  2 accepted prefixes
  Accepted AD:0 MACIP:1 MCAST:1 ESI:0 PREFIX:0
  2 announced prefixes

 Connections established 5; dropped 4
Local host: 10.10.100.1, Local port: 179
Foreign host: 10.10.100.3, Foreign port: 33649
TCP MSS: (0), Advertise TCP MSS: (1460), Send TCP MSS: (1460),  Receive TCP MSS: (536)
Sock FD : (24)
Nexthop: 10.10.100.1
Nexthop global: ::
Nexthop local: ::
BGP connection: non shared network
Last Reset: 02w4d00h, due to BGP Notification received
Notification Error Message: (Cease/Other Configuration Change.)

uk-wnlb-lg-pol-cin-01#









Code Block
titleping
AGGR1#ping 192.168.203.1 vrf l3vpn
Press CTRL+C to exit
PING 192.168.203.1 (192.168.203.1) 56(84) bytes of data.
64 bytes from 192.168.203.1: icmp_seq=1 ttl=64 time=0.486 ms
64 bytes from 192.168.203.1: icmp_seq=2 ttl=64 time=0.508 ms

--- 192.168.203.1 ping statistics ---
2 packets transmitted, 2 received, 0% packet loss, time 4ms
rtt min/avg/max/mdev = 0.486/0.497/0.508/0.011 ms


AGGR1#ping 192.168.204.1 vrf l3vpn
Press CTRL+C to exit
PING 192.168.204.1 (192.168.204.1) 56(84) bytes of data.
64 bytes from 192.168.204.1: icmp_seq=1 ttl=64 time=0.657 ms

--- 192.168.204.1 ping statistics ---
1 packets transmitted, 1 received, 0% packet loss, time 0ms
rtt min/avg/max/mdev = 0.657/0.657/0.657/0.000 ms