Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

...





Code Block
titleInterfaces
collapsetrue
root@ACX5048-R103# top show interfaces ge-0/0/34
vlan-tagging;
encapsulation vlan-vpls;
unit 600 {
    encapsulation vlan-vpls;
    vlan-id 600;
    family vpls;
}

set interfaces ge-0/0/34 vlan-tagging
set interfaces ge-0/0/34 encapsulation vlan-vpls
set interfaces ge-0/0/34 unit 600 encapsulation vlan-vpls
set interfaces ge-0/0/34 unit 600 vlan-id 600
set interfaces ge-0/0/34 unit 600 family vpls


{master:0}[edit routing-instances VPLS2]
root@ACX5048-R103# top show interfaces ge-0/0/36
vlan-tagging;
encapsulation vlan-vpls;
unit 600 {
    encapsulation vlan-vpls;
    vlan-id 600;
    family vpls;
}


show ldp database


Code Block
titleOSPF, MPLS and LDP
collapsetrue
{master:0}[edit routing-instances VPLS2]
root@ACX5048-R103# top show protocols
ldp {
    interface ge-0/0/0.0;
    interface lo0.0;
    oam {
        ingress-policy ldp-oam;
        bfd-liveness-detection {
            minimum-interval 300;
        }
        lsp-ping-interval 30;
    }
}

ospf {
    traffic-engineering;
    area 0.0.0.0 {
        interface ge-0/0/0.0;
        interface lo0.0;
    }
}
mpls {
    interface ge-0/0/0.0;
}
lldp {
    interface all;
}

{master:0}[edit routing-instances VPLS2]
root@ACX5048-R103# top show protocols | display set
set protocols ldp interface ge-0/0/0.0
set protocols ldp interface lo0.0
set protocols ldp oam ingress-policy ldp-oam
set protocols ldp oam bfd-liveness-detection minimum-interval 300
set protocols ldp oam lsp-ping-interval 30

set protocols ospf traffic-engineering
set protocols ospf area 0.0.0.0 interface ge-0/0/0.0
set protocols ospf area 0.0.0.0 interface lo0.0

set protocols mpls interface ge-0/0/0.0
set protocols lldp interface all


Code Block
titleshow ospf database
collapsetrue
root@ACX5048-R103> show ospf database

    OSPF database, Area 0.0.0.0
 Type       ID               Adv Rtr           Seq      Age  Opt  Cksum  Len
Router  *10.99.92.95      10.99.92.95      0x80000081  1199  0x22 0x1ff   48
Router   10.99.92.177     10.99.92.177     0x80000080  1113  0x22 0x3ecd  60
Network *10.99.70.95      10.99.92.95      0x8000007d   199  0x22 0x5e7e  32
OpaqArea*1.0.0.1          10.99.92.95      0x8000007c  2199  0x22 0x570a  28


{master:0}
root@ACX5048-R103> show ospf database extensive

    OSPF database, Area 0.0.0.0
 Type       ID               Adv Rtr           Seq      Age  Opt  Cksum  Len
Router  *10.99.92.95      10.99.92.95      0x80000081  1204  0x22 0x1ff   48
  bits 0x0, link count 2
  id 10.99.70.95, data 10.99.70.95, Type Transit (2)
    Topology count: 0, Default metric: 1
  id 10.99.92.95, data 255.255.255.255, Type Stub (3)
    Topology count: 0, Default metric: 0
  Topology default (ID 0)
    Type: Transit, Node ID: 10.99.70.95
      Metric: 1, Bidirectional
  Gen timer 00:29:55
  Aging timer 00:39:55
  Installed 00:20:04 ago, expires in 00:39:56, sent 00:20:02 ago
  Last changed 4d 06:50:44 ago, Change count: 5, Ours
Router   10.99.92.177     10.99.92.177     0x80000080  1118  0x22 0x3ecd  60
  bits 0x0, link count 3
  id 10.99.70.95, data 10.99.70.177, Type Transit (2)
    Topology count: 0, Default metric: 1
  id 10.99.92.177, data 255.255.255.255, Type Stub (3)
    Topology count: 0, Default metric: 0
  id 192.168.255.51, data 255.255.255.255, Type Stub (3)
    Topology count: 0, Default metric: 0
  Topology default (ID 0)
    Type: Transit, Node ID: 10.99.70.95
      Metric: 1, Bidirectional
  Aging timer 00:41:21
  Installed 00:18:35 ago, expires in 00:41:22
  Last changed 4d 06:49:19 ago, Change count: 3
Network *10.99.70.95      10.99.92.95      0x8000007d   204  0x22 0x5e7e  32
  mask 255.255.255.0
  attached router 10.99.92.95
  attached router 10.99.92.177
  Topology default (ID 0)
    Type: Transit, Node ID: 10.99.92.177
      Metric: 0, Bidirectional
    Type: Transit, Node ID: 10.99.92.95
      Metric: 0, Bidirectional
  Gen timer 00:46:35
  Aging timer 00:56:35
  Installed 00:03:24 ago, expires in 00:56:36, sent 00:03:22 ago
  Last changed 4d 06:52:14 ago, Change count: 1, Ours
OpaqArea*1.0.0.1          10.99.92.95      0x8000007c  2204  0x22 0x570a  28
Opaque LSA
  RtrAddr (1), length 4:
    10.99.92.95
  Gen timer 00:13:15
  Aging timer 00:23:15
  Installed 00:36:44 ago, expires in 00:23:16, sent 00:36:42 ago
  Last changed 4d 06:53:03 ago, Change count: 1, Ours

{master:0}
root@ACX5048-R103>


Code Block
titleshow ldp database
collapsetrue
{master:0}
root@ACX5048-R203> show ldp database
Input label database, 10.99.92.177:0--10.99.92.95:0
Labels received: 3
  Label     Prefix
      3      10.99.92.95/32
     25      10.99.92.177/32
     26      L2CKT NoCtrlWord ETHERNET VC 600

Output label database, 10.99.92.177:0--10.99.92.95:0
Labels advertised: 3
  Label     Prefix
     25      10.99.92.95/32
      3      10.99.92.177/32
     27      L2CKT NoCtrlWord ETHERNET VC 600


{master:0}
root@ACX5048-R203> show ldp database detail
Input label database, 10.99.92.177:0--10.99.92.95:0
Labels received: 3
  Label     Prefix
      3      10.99.92.95/32
            State: Active
            Age: 3d 8:28:56
            Entropy Label Capability: No
     25      10.99.92.177/32
            State: Active
            Age: 3d 8:28:56
            Entropy Label Capability: No
     26      L2CKT NoCtrlWord ETHERNET VC 600
            MTU: 1500 Flow Label T Bit: 0 Flow Label R Bit: 0
            State: Active
            Age: 3:56:28
            VCCV Control Channel types:
                MPLS router alert label
            VCCV Control Verification types:
                LSP ping
                BFD with IP/UDP-encapsulation for Fault Detection

Ou



Code Block
titlevpls
collapsetrue
{master:0}
root@ACX5048-R103> show ldp database
Input label database, 10.99.92.95:0--10.99.92.177:0
Labels received: 3
  Label     Prefix
     25      10.99.92.95/32
      3      10.99.92.177/32
     27      L2CKT NoCtrlWord ETHERNET VC 600

Output label database, 10.99.92.95:0--10.99.92.177:0
Labels advertised: 3
  Label     Prefix
      3      10.99.92.95/32
     25      10.99.92.177/32
     26      L2CKT NoCtrlWord ETHERNET VC 600


{master:0}
root@ACX5048-R103> show ldp database extensive
Input label database, 10.99.92.95:0--10.99.92.177:0
Labels received: 3
  Label     Prefix
     25      10.99.92.95/32
            State: Active
            Age: 3d 8:30:48
            Entropy Label Capability: No
      3      10.99.92.177/32
            State: Active
            Age: 3d 8:30:48
            Entropy Label Capability: No
     27      L2CKT NoCtrlWord ETHERNET VC 600
            MTU: 1500 Flow Label T Bit: 0 Flow Label R Bit: 0
            State: Active
            Age: 3:42:32
            VCCV Control Channel types:
                MPLS router alert label
            VCCV Control Verification types:
                LSP ping
                BFD with IP/UDP-encapsulation for Fault Detection

Output label database, 10.99.92.95:0--10.99.92.177:0
Labels advertised: 3
  Label     Prefix
      3      10.99.92.95/32
            State: Active
            Age: 3d 8:30:48
            Entropy Label Capability: No
     25      10.99.92.177/32
            State: Active
            Age: 3d 8:30:48
            Entropy Label Capability: No
     26      L2CKT NoCtrlWord ETHERNET VC 600
            MTU: 1500 Flow Label T Bit: 0 Flow Label R Bit: 0
            State: Active
            Age: 3:58:18
            VCCV Control Channel types:
                MPLS router alert label
            VCCV Control Verification types:
                LSP ping
                BFD with IP/UDP-encapsulation for Fault Detection

{master:0}
root@ACX5048-R103>





Code Block
titleshow vpls mac-table
collapsetrue
{master:0}
root@ACX5048-R103> show vpls mac-table

MAC flags (S - static MAC, D - dynamic MAC, L - locally learned, P - Persistent static, C - Control MAC
           SE - statistics enabled, NM - non configured MAC, R - remote PE MAC, O - ovsdb MAC)


Ethernet switching table : 3 entries, 3 learned
Routing instance : VPLS2
    Vlan                MAC                 MAC         Age    Logical                NH        RTR
    name                address             flags              interface              Index     ID
    __VPLS2__           c8:e7:f0:a9:90:a5   D             -   lsi.1048576            0         0
    __VPLS2__           c8:e7:f0:a9:90:a7   D             -   ge-0/0/36.600          0         0
    __VPLS2__           c8:e7:f0:a9:93:45   D             -   ge-0/0/34.600          0         0

{master:0}



{master:0}
root@ACX5048-R103> show vpls mac-table extensive

MAC address: c8:e7:f0:a9:90:a5
  Routing instance: VPLS2
  VLAN name: __VPLS2__, VLAN ID: NA
   Learning interface: lsi.1048576
   Layer 2 flags: in_hash,in_ifd,in_ifl,in_vlan,in_rtt,kernel,in_ifbd
   Epoch: 0                            Sequence number: 5
   Learning mask: 0x00000001

MAC address: c8:e7:f0:a9:90:a7
  Routing instance: VPLS2
  VLAN name: __VPLS2__, VLAN ID: NA
   Learning interface: ge-0/0/36.600
   Layer 2 flags: in_hash,in_ifd,in_ifl,in_vlan,in_rtt,kernel,in_ifbd
   Epoch: 2                            Sequence number: 4
   Learning mask: 0x00000001

MAC address: c8:e7:f0:a9:93:45
  Routing instance: VPLS2
  VLAN name: __VPLS2__, VLAN ID: NA
   Learning interface: ge-0/0/34.600
   Layer 2 flags: in_hash,in_ifd,in_ifl,in_vlan,in_rtt,kernel,in_ifbd
   Epoch: 4                            Sequence number: 4
   Learning mask: 0x00000001





Code Block
titleshow vpls connections
collapsetrue
{master:0}
root@ACX5048-R103> show vpls connections
Layer-2 VPN connections:

Legend for connection status (St)
EI -- encapsulation invalid      NC -- interface encapsulation not CCC/TCC/VPLS
EM -- encapsulation mismatch     WE -- interface and instance encaps not same
VC-Dn -- Virtual circuit down    NP -- interface hardware not present
CM -- control-word mismatch      -> -- only outbound connection is up
CN -- circuit not provisioned    <- -- only inbound connection is up
OR -- out of range               Up -- operational
OL -- no outgoing label          Dn -- down
LD -- local site signaled down   CF -- call admission control failure
RD -- remote site signaled down  SC -- local and remote site ID collision
LN -- local site not designated  LM -- local site ID not minimum designated
RN -- remote site not designated RM -- remote site ID not minimum designated
XX -- unknown connection status  IL -- no incoming label
MM -- MTU mismatch               MI -- Mesh-Group ID not available
BK -- Backup connection          ST -- Standby connection
PF -- Profile parse failure      PB -- Profile busy
RS -- remote site standby        SN -- Static Neighbor
LB -- Local site not best-site   RB -- Remote site not best-site
VM -- VLAN ID mismatch           HS -- Hot-standby Connection

Legend for interface status
Up -- operational
Dn -- down

Instance: VPLS2
  VPLS-id: 600
    Neighbor                  Type  St     Time last up          # Up trans
    10.99.92.177(vpls-id 600) rmt   Up     Jan 21 16:08:06 2019           1
      Remote PE: 10.99.92.177, Negotiated control-word: No
      Incoming label: 26, Outgoing label: 27
      Negotiated PW status TLV: No
      Local interface: lsi.1048576, Status: Up, Encapsulation: ETHERNET
        Description: Intf - vpls VPLS2 neighbor 10.99.92.177 vpls-id 600
      Flow Label Transmit: No, Flow Label Receive: No


syntax error, expecting <command>.
root@ACX5048-R103> show vpls connections extensive
Layer-2 VPN connections:

. . . . 

Instance: VPLS2
  VPLS-id: 600
    Number of local interfaces: 2
    Number of local interfaces up: 2
    ge-0/0/34.600
    ge-0/0/36.600
    lsi.1048576                   Intf - vpls VPLS2 neighbor 10.99.92.177 vpls-id 600
    Neighbor                  Type  St     Time last up          # Up trans
    10.99.92.177(vpls-id 600) rmt   Up     Jan 21 16:08:06 2019           1
      Remote PE: 10.99.92.177, Negotiated control-word: No
      Incoming label: 26, Outgoing label: 27
      Negotiated PW status TLV: No
      Local interface: lsi.1048576, Status: Up, Encapsulation: ETHERNET
        Description: Intf - vpls VPLS2 neighbor 10.99.92.177 vpls-id 600
      Flow Label Transmit: No, Flow Label Receive: No
    Connection History:
        Jan 21 16:20:43 2019  Out lbl Update                        27
        Jan 21 16:08:06 2019  status update timer
        Jan 21 16:08:06 2019  PE route changed
        Jan 21 16:08:06 2019  Out lbl Update                        26
        Jan 21 16:08:06 2019  In lbl Update                         26
        Jan 21 16:08:06 2019  loc intf up                  lsi.1048576

{master:0}
root@ACX5048-R103>




Code Block
titlevpls Vlan on the EX ( trunk interfaces)
collapsetrue
{master:0}
root@EX4300-R103-33> show configuration routing-instances
CE3 interfaces ge-0/0/34
flexible-vlan-tagging;
unit 0 {
    family ethernet-switching {
##     ## Warning: requires 'virtualinterface-router'mode licensetrunk;
    ##    vlan instance-type virtual-router;{
     inactive: interface ge-0/0/34.600;     interface ge-0/0/36.600members vlan600;
    interface lo0.600; }  }
    }
}

{master:0}
root@EX4300-R103-33> show configuration routing-instances | display set
set routing-instances CE3 instance-type virtual-router
set routing-instances CE3 interface ge-0/0/34.600
deactivate routing-instances CE3 interface ge-0/0/34.600
set routing-instances CE3 interface ge-0/0/36.600
set routing-instances CE3 interface lo0.600
interfaces ge-0/0/36
flexible-vlan-tagging;
unit 0 {
    family ethernet-switching {
        interface-mode trunk;
        vlan {
            members vlan600;
        }
    }
}

{master:0}
root@EX4300-R103-33> show configuration interfaces ge-0/0/34 | display set
set interfaces ge-0/0/34 flexible-vlan-tagging
set interfaces ge-0/0/34 unit 0 family ethernet-switching interface-mode trunk
set interfaces ge-0/0/34 unit 0 family ethernet-switching vlan members vlan600

set interfaces ge-0/0/36 flexible-vlan-tagging
set interfaces ge-0/0/36 unit 0 family ethernet-switching interface-mode trunk
set interfaces ge-0/0/36 unit 0 family ethernet-switching vlan members vlan600


{master:0}
root@EX4300-R103-33> show configuration vlans
default {
    vlan-id 1;
    l3-interface irb.0;
}
vlan600 {
    vlan-id 600;
    l3-interface irb.600;
}

{master:0}
root@EX4300-R103-33> show configuration vlans | display set
. . .
set vlans vlan600 vlan-id 600
set vlans vlan600 l3-interface irb.600


Code Block
titleshow commands on the EX
collapsetrue
{master:0}
root@EX4300-R103-33> show ethernet-switching interface
Routing Instance Name : default-switch
Logical Interface flags (DL - disable learning, AD - packet action drop,
                         LH - MAC limit hit, DN - interface down,
                         MMAS - Mac-move action shutdown,  AS - Autostate-exclude enabled,
                         SCTL - shutdown by Storm-control, MI - MAC+IP limit hit)

Logical         Vlan                   TAG   MAC    MAC+IP STP         Logical          Tagging
interface       members                      limit  limit  state       interface flags
ge-0/0/34.0                                  65535  8192                                tagged
                vlan600                600   65535  1024   Forwarding                   tagged
ge-0/0/36.0                                  65535  8192                                tagged
                vlan600                600   65535  1024   Forwarding                   tagged
ge-0/0/3.0                                   65535  8192               DN               untagged
                default                1     65535  1024   Discarding                   untagged


{master:0}
root@EX4300-R103-33> show ethernet-switching table vlan-id 600

MAC flags (S - static MAC, D - dynamic MAC, L - locally learned, P - Persistent static, C - Control MAC
           SE - statistics enabled, NM - non configured MAC, R - remote PE MAC, O - ovsdb MAC)


Ethernet switching table : 1 entries, 1 learned
Routing instance : default-switch
    Vlan                MAC                 MAC         Age    Logical                NH        RTR
    name                address             flags              interface              Index     ID
    vlan600             c8:e7:f0:a9:93:45   D             -   ge-0/0/36.0            0         0


root@EX4300-R103-33> show ethernet-switching instance
Information for routing instance and VLAN:

Flags (DL - disable learning, SE - stats enabled,
       AD - packet action drop, LH - MAC limit hit,
       MI - mac+ip limit hit)

Inst Logical   Routing             VLAN               Index IRB   Flags Tag
type system    instance                                     index
RTT  Default   default-switch                         5
vlan Default   default-switch      default            2     548         1
vlan Default   default-switch      vlan600            3     595         600


{master:0}
root@EX4300-R103-33> show interfaces terse irb
Interface               Admin Link Proto    Local                 Remote
irb                     up    up
irb.0                   up    down inet
irb.600                 up    up   inet     10.99.50.195/24



{master:0}
root@EX4300-R103-33> show vlans vlan600

Routing instance        VLAN name             Tag          Interfaces
default-switch          vlan600               600
                                                           ge-0/0/34.0*
                                                           ge-0/0/36.0*

{master:0}
root@EX4300-R103-33> show vlans vlan600 detail

Routing instance: default-switch
VLAN Name: vlan600                        State: Active
Tag: 600
Internal index: 3, Generation Index: 3, Origin: Static
MAC aging time: 300 seconds
Layer 3 interface: irb.600
VXLAN Enabled : No
Interfaces:
    ge-0/0/34.0*,tagged,trunk
    ge-0/0/36.0*,tagged,trunk
Number of interfaces: Tagged 2    , Untagged 0
Total MAC count: 1

{master:0}